Documentation

From Metabolite Detector
Revision as of 19:15, 6 December 2010 by Khi (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Data Import

At the moment, MetaboliteDetector supports the import of raw GC/MS data in netCDF and FastFlight2 format. Furthermore, existing reference libraries can be imported if they are in the common NIST format.

GC/MS Data

netCDF format

NetCDF import dialog of MetaboliteDetector

Importing GC/MS data in netCDF format is simple:

  • Open MetaboliteDetector
  • Choose menu "File->Import->NetCDF import"
  • When the netCDF import dialog has opened click
  • Folder.png to select single netCDF files or
  • Recursive.png to recursiveley search for all netCDF files in all subfolders
  • Remove.png to remove selected files
  • Select an output folder where MetaboliteDetector can save the imported data.
  • Hit "OK"


During data import and further operation MetaboliteDetector may creates these files:

File Extensions
Extension Description Needed
*.bin contains the actual chromatographic data YES
*.idx contains index information about the *.bin file YES
*.cmp contains information about compounds detected by MetaboliteDetector NO


ATTENTION: If you intend to copy imported GC/MS data you must copy at least the .bin and .idx files!

FastFlight2 raw files

NIST Library

Main Window

Opening an imported GC/MS chromatogram

Once the netCDF or FastFlight2 data of a GC/MS chromatogram has been imported it can be opened by either choosing the Menu "File->Open..." or by clicking the "Open" button Folder.png located on the toolbar.

Inspection of the GC/MS data

Main Window of MetaboliteDetector


TIC

TIC display of MetaboliteDetector

The TIC is displayed in the upper part of the user interface of MetaboliteDetector.

  • Zoom.png Zoom: If the Zoom button is checked the following operations can be performed with the mouse:
    • left button: Pressing the left button and at the same time moving the mouse zooms into the selected part of the chromatogram
    • right button: Clicking the right button zooms one step out
    • middle button Pressing the middle button and at the time moving the mouse moves the displayed chromatogram


  • Slider.png Slider: If the Slider button is checked a slider appears and can be moved inside the TIC with the mouse. The mass spectrum at the selected time point is displayed in the "Spectrum" tab at the lower part of MetaboliteDetector's user interface.


  • Info.png Info: If a deconvolution process (compound detection) has been performed, potential compounds are marked by colored triangeles. If the info button is checked and one of the triangles is selected with the left mouse button, the "Compound Information" tab at the lower part of the user interface displays information about the selected compound (see screenshot of the main window).


Spectrum Tab

Spectrum tab of MetaboliteDetector

The selected mass spectrum is shown in the lower part of MetaboliteDetector's user interface. In the case that the "Spectrum" tab is overlayed by another tab it can be brought to front by clicking on its corresponding tab. The active mass spectrum can be selected by the following actions:

  • Moving the "Slider" in the TIC: The spectrum of the corresponding retention time is shown.
  • Manually changing the current scan number in the "Spectrum" tab toolbar: The mass spectrum of the selected scan is shown (see screenshot of "Spectrum" tab).
  • Manually changing the current retention time in the "Spectrum" tab toolbar: The mass spectrum of the selected retention time is shown (see screenshot of "Spectrum" tab).


The following actions can be performed within the "Spectrum" tab:

  • Zoom in and out as described for the #TIC.
  • Slider: The slider appears once a double click with the left mouse button is performed inside the spectrum. Subsequently, the slider can be moved with the mouse. The position of the slider selects the SIC that will be displayed in the "SIC" tab.
  • Export image.png: Click this button to export the displayed spectrum view as an image. MetaboliteDetector supports many image formats including PNG, GIF, TIF and JPG. The export format as well as the desired image size can be chosen in the "Image Export" dialog.
  • Export csv.png: Click this button to export the displayed spectrum view as CSV data. These data can be exported by most spreadsheet programs like OpenOffice or Excel.
  • Detach.png: The detach button can be found at the upper right border of the "Spectrum" tab (screenshot of the "Spectrum" tab). Once the detach button has been clicked, the "Spectrum" tab can be placed with the mouse at any position of the screen. Furthermore, the tab can be docked at many places inside the MetaboliteDetector window.
  • Close.png: The close button can be found at the upper right border of the "Spectrum" tab (screenshot of the "Spectrum" tab). Once the close button has been clicked, the "Spectrum" tab will be hidden. The tab can be made visible again by choosing the main menu "View->Spectrum".


SIC (Single Ion Chromatogram) Tab

RI Calibration Wizard

The RI calibration wizard facilitates the steps needed for compound detection and RI calculation. In order to succesfully apply an accurate RI calbration the following requirements should be fullfilled:

  1. The GC/MS data of all chromatograms of interest have to be imported into MetaboliteDetector. If the highest RI accuracy is desired a particular compound should be added to all samples before measurement.
  2. Additionally, a chromatogram containing a set of n-alkanes must be provided. This chromatogram is needed for the RI calculation.
  3. A reference compound library containing the compounds of the n-alkane chromatogram must be prepared either with MeatboliteDetector or an existing library in NIST format can be imported.
Attention: it is essential that a valid RI has been set for all compounds of the n-alkane mix! Before starting the calibration wizard check the RIs of the specific compounds with the Library Editor of MetboliteDetector.


  • The RI calibration wizard is opened by choosing menu "Tools->RI-calibration wizard..." (see screenshot).
  • When the "Next" button is hit, the wizard requests the imported chromatogram of the reference compounds (n-alkane mix) (see screenshot).
RI calibration wizard of MetaboliteDetector: page 1
RI calibration wizard of MetaboliteDetector: page 2


  • During the next step a calibration mix (e.g. n-alkane mix) has to be defined. For this purpose, a reference library must be selected. All compounds contained in the library will then be displayed in the left list. Compounds to be added to the calibration mix need to be selected in the left list. After hitting the button ">>" these compounds are appended to the calibartion mix (right list). Compounds can be removed from the calibration mix by selecting them and subsequntly clicking the "<<" button (see screenshot). When all compounds have been added the "Next" button must be clicked to continue.
  • MetaboliteDetectors opens the chosen reference chromatogram and trys to detect all compounds. The selected chromatogram is shown in the main window and can be explored as described in chapter "Main Window". At the same time, the RI calibration wizard opens a table which assigns the detected retention times to the selected Ris (see screenshot). The first column shows the name of the reference compound, the second column the detected retention time and the third column the RI deposited in the reference library. The whole table should be carefully inspected for potential assignment errors. If MetaboliteDetector has misassigned a calibration pair, the misassigned retention time can be edited manually: Either the known retention time can directly be entered or a list of all detected retention times can be opened by double clicking the particular cell. In the case that one or more compounds of the calibration mix have not been detected, the corresponding cell inside the table is marked in red. It is absolutely necessary to enter valid retention times into these cells!
RI calibration wizard of MetaboliteDetector: page 3
RI calibration wizard of MetaboliteDetector: page 4


  • The next wizard page allows for the advanced RI calibration. The upper part of the page shows the calibration table that was defined in the previous step. If a specific compound has been added to all samples before measurement, an advanced RI calibration can be performed: During the RI calibration process, MetaboliteDetector trys to identify this compound and shifts the whole chromatogram in the retention time dimension to exactly match the RI that has been deposited in the reference library for this compound. If "Enable advanced calibration" is checked, a reference library containing data for the calibration compound has to be selected. Afterwards, this compounds must be selected in the "Calib. compound" list. Furthermore, the minimal similarity score should be adjusted (see screenshot).
Attention: It must be ensured that a valid retention index for the "Calib. compound" was deposited inside the reference library! This can be checked or may edited with the Library Editor of MetaboliteDetector.
  • Now it is time to select the ( imported) chromatograms for which an RI calibration based on the chosen n-alkane mix should be performed. Clicking the Add.png button opens a file chooser for selcting these chromatograms. Selected chromatograms can be removed by clicking the Remove.png button (see screenshot).
RI calibration wizard of MetaboliteDetector: page 5
RI calibration wizard of MetaboliteDetector: page 6


  • In order to detect all compounds of the selected chromatograms a deconvolution step will be performed for each chromatogram. Therefore, some settings have to be adjusted in this wizard page. For a detailed explanation of these values check the settings chapter of this manual (see screenshot).
  • Once all information have been collected the final step consitsts of clicking the "Start" button of the last wizard page (screenshot). Depending on the number of selected chromatograms and the used hardware this process can last some minutes.
RI calibration wizard of MetaboliteDetector: page 7
RI calibration wizard of MetaboliteDetector: page 8


Compound Detection / Deconvolution

Batch Analysis / Chromatogram Alignment

Settings

Recommended and tested settings for different GC-MS instruments


Deconvolution

Settings-deconv.png


Identification

Settings-ident.png

  • "Max RI difference": The score for the retention index similarity is calculated by this formula:

<math>S_{RI}=e^{\frac{(RI(c_1)-RI(c_2))^2}{2\cdot {\sigma}^2}}</math>

Agilent 6890 GC / 5975B MS

Recommended settings:

  • Peak threshold: 2-10 (2 high sensitivity, 10 low sensitivity)
  • Minimum peak height: 2-10 (2 high sensitivity, 10 low sensitivity)
  • Number of bins per scan: 10
  • Deconvolution width (scans): 7.0-8.0

Jeol AccuTOF

Recommended settings for Jeol AccuTOF

  • Peak threshold: 5-20 (5 high sensitivity, 20 low sensitivity)
  • Minimum peak height: 5-20 (5 high sensitivity, 20 low sensitivity)
  • Number of bins per scan: 10
  • Deconvolution width (scans): 1.0

Trace

Recommended settings for TRACE

  • Peak threshold: 50-100 (50 high sensitivity, 100 low sensitivity)
  • Minimum peak height: 5-20 (5 high sensitivity, 20 low sensitivity)
  • Number of bins per scan: 10
  • Deconvolution width (scans): 3.0

Trace (modified / experimental / high sensitivity)

Recommended settings for TRACE

  • Peak threshold: 150
  • Minimum peak height: 10
  • Number of bins per scan: 10
  • Deconvolution width (scans): 3

LECO GC/TOF

Recommended settings for LECO

  • Peak threshold: 20-50 (20 high sensitivity, 50 low sensitivity)
  • Minimum peak height: 20-50 (20 high sensitivity, 50 low sensitivity)
  • Number of bins per scan: 1
  • Deconvolution width (scans): 40.0

Library Editor

Videos

Description Video
FastFlight import This video demonstrates the import of FastFlight GC-MS raw data into MetaboliteDetector
FastFlight import
Retention Index (RI) Calibration This video demonstrates the use of the RI calibration wizard of MetaboliteDetector.
RI calibration
Personal tools
Namespaces

Variants
Actions
Navigation
Tools